Advisory record · GHSA-2gh6-wc3m-g37f

hermes-management is vulnerable to RCE due to Apache commons-jxpath

CVSS 9.8 CriticalCritical

Critical, because:

  • CVSS score 9.8: 9.0 or more.

How we decide what’s critical

Published by the GitHub Advisory Database at 17 Sept 2024, 19:29 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
pl.allegro.tech.hermes:hermes-managementMaven>=0.8.2, <2.2.92.2.9
Identifiers
GHSA-2gh6-wc3m-g37f
Weakness (CWE)
CWE-1395
Published
17 Sept 2024
Updated
31 Aug 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

hermes-management is vulnerable to remote code execution in versions from 0.8.2 before 2.2.9. The source gives few details beyond saying the flaw is triggered when the package processes user-controlled data through Apache commons-jxpath. Upgrade hermes-management to version 2.2.9 or later.

Written 2 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
9.8 Critical 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS No score.

Timeline

  1. 31 Oct 2026, 14:18 UTC First seen by agentprime
  2. 31 Oct 2026, 14:18 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.