Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Nginx UI (github.com/0xJacky/Nginx-UI) versions before 1.9.10-0.20260703131214-23d1934099b0 are affected. An authenticated user can change the password of any other account, including the initial admin account, through the user management endpoint because it does not require the secure session (2FA) check that the self password change endpoint enforces. This allows full takeover of the admin account. Upgrade to 1.9.10-0.20260703131214-23d1934099b0 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.7 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0042, the 36th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:11 UTC First seen by agentprime
- 31 Oct 2026, 14:11 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-2gc7-j998-5xx6
- OSV: GHSA-2gc7-j998-5xx6
- github.com/0xJacky/nginx-ui/security/advisories/GHSA-2gc7-j998-5xx6
- nvd.nist.gov/vuln/detail/CVE-2026-84314
- github.com/0xJacky/nginx-ui/commit/23d1934099b05b2a01589b48129dc3d3159d91c2
- github.com/0xJacky/nginx-ui
- github.com/0xJacky/nginx-ui/releases/tag/v2.4.1