Advisory record · GHSA-2c9m-w27f-53rm

Apache Tomcat vulnerable to Unprotected Transport of Credentials

CVSS 4.3 MediumEPSS 0.018 · 78th percentile

Published by the GitHub Advisory Database at 22 Mar 2023, 12:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
org.apache.tomcat:tomcat-catalinaMaven>=11.0.0-M1, <11.0.0-M3 || >=10.1.0-M1, <10.1.6 || >=9.0.0-M1, <9.0.72 || >=8.5.0, <8.5.8611.0.0-M3, 10.1.6, 9.0.72, 8.5.86
Identifiers
GHSA-2c9m-w27f-53rm · BIT-tomcat-2023-28708 · CVE-2023-28708
Weakness (CWE)
CWE-523
Published
22 Mar 2023
Updated
24 Mar 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Apache Tomcat (tomcat-catalina) versions 11.0.0-M1 to 11.0.0-M2, 10.1.0-M1 to 10.1.5, 9.0.0-M1 to 9.0.71, and 8.5.0 to 8.5.85 are affected when the RemoteIpFilter handles requests from a reverse proxy over HTTP that set X-Forwarded-Proto to https. In these cases, session cookies lack the secure attribute, so a browser may send the session cookie over an insecure connection, where an attacker who can observe network traffic could capture it. Upgrade to 11.0.0-M3, 10.1.6, 9.0.72, 8.5.86 or later.

Written 3 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
4.3 Medium 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS 0.018, the 78th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:20 UTC First seen by agentprime
  2. 31 Oct 2026, 14:20 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.