Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The awslabs-aws-api-mcp-server package, versions 0.2.13 up to but not including 1.3.47, is affected. If the security policy data fails to load at startup, the server keeps running and skips the per-request policy check for the life of the process, so operations the policy meant to deny or gate can run. IAM permissions still limit what the server can do. Upgrade to version 1.3.47 or later; until then, use least-privilege IAM credentials and restart the server once connectivity is restored if it started during an outage.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.3 | High | 4.0 | CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA (AMZN) |
- CISA KEV Not listed.
- EPSS 0.0023, the 13th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:40 UTC First seen by agentprime
- 31 Oct 2026, 14:40 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-29w2-fq35-v728
- OSV: GHSA-29w2-fq35-v728
- github.com/awslabs/mcp/security/advisories/GHSA-29w2-fq35-v728
- nvd.nist.gov/vuln/detail/CVE-2026-16584
- github.com/awslabs/mcp/pull/4315
- github.com/awslabs/mcp/commit/ab1bbebc097d674c1cdd4bd75a8f313be18473bf
- aws.amazon.com/security/security-bulletins/2026-063-aws
- github.com/awslabs/mcp
- pypi.org/project/awslabs.aws-api-mcp-server/1.3.47