Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
vLLM versions before 0.30.0 are affected, with 0.25.1 confirmed; the advisory notes the lower bound is unclear. On deployments with the built-in LMCache-MP KV connector enabled (lmcache 0.4.4 or later), the cache_salt request field is validated too loosely and then passed to a stricter downstream library that raises an uncaught ValueError. A single publicly reachable request with a crafted cache_salt value can therefore crash the engine process and deny service to all users. Upgrade to vLLM 0.30.0 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.5 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0033, the 26th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:08 UTC First seen by agentprime
- 31 Oct 2026, 14:08 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-2823-qmq8-rwvj
- OSV: GHSA-2823-qmq8-rwvj
- github.com/vllm-project/vllm/security/advisories/GHSA-2823-qmq8-rwvj
- github.com/vllm-project/vllm/pull/51444
- github.com/vllm-project/vllm/commit/e962733e08d10f7ca65dac4df99e116460b8b174
- github.com/vllm-project/vllm
- github.com/vllm-project/vllm/releases/tag/v0.30.0