Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Apache Camel's camel-platform-http-main module is vulnerable to an authentication bypass in versions 4.14.1 to before 4.14.6, 4.18.0 to before 4.18.2, and 4.19.0 to before 4.20.0. When authentication is enabled and a non-root context path is configured, requests to subpaths of that path are not challenged for credentials, so an unauthenticated remote attacker can reach protected routes and management endpoints. Upgrade to 4.14.6, 4.18.2, or 4.20.0 depending on your release line.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.2 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.0094, the 60th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:17 UTC First seen by agentprime
- 31 Oct 2026, 14:17 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-27vm-5vpj-rp5g
- OSV: GHSA-27vm-5vpj-rp5g
- nvd.nist.gov/vuln/detail/CVE-2026-40022
- github.com/apache/camel/pull/22474
- github.com/apache/camel/pull/22475
- github.com/apache/camel/pull/22476
- github.com/apache/camel/commit/6ec12cbebfc1b6360cdaac1c1f8c681864911695
- github.com/apache/camel/commit/7b5b8c0283c0ab8d703d868ded7614018762a553
- github.com/apache/camel/commit/a9ebee94af976ac2afd7906d2e76673067d8be86
- camel.apache.org/security/CVE-2026-40022.html
- github.com/apache/camel
- www.openwall.com/lists/oss-security/2026/04/26/5