Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Packetbeat in github.com/elastic/beats/v7 versions before 7.0.0-alpha2.0.20260126223743-dec1b31111ec is affected by improper array index validation in several protocol parsers. An attacker who can send crafted, malformed packets to a monitored network interface, either from the same network segment or by controlling traffic routed to it, can trigger out-of-bounds reads that crash the application or exhaust resources. Upgrade to 7.0.0-alpha2.0.20260126223743-dec1b31111ec or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.7 | Medium | 3.1 | CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H | CNA (elastic) |
- CISA KEV Not listed.
- EPSS 0.0024, the 14th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:14 UTC First seen by agentprime
- 31 Oct 2026, 14:14 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-27qj-9gvp-8rh9
- OSV: GHSA-27qj-9gvp-8rh9
- nvd.nist.gov/vuln/detail/CVE-2026-26933
- github.com/elastic/beats/commit/941098459db6556b837194f40c076b08d51137cb
- github.com/elastic/beats/commit/dec1b31111ec3500b82db21ba67dde5c914ee94d
- discuss.elastic.co/t/packetbeat-8-19-11-9-2-5-security-update-esa-2026-11/385533
- github.com/elastic/beats