Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
frp versions 0.53.0 through 0.70.0 are vulnerable to an integer overflow in the frps SSH Tunnel Gateway when it parses SSH exec requests, but only when the gateway is enabled. An unauthenticated remote attacker can crash the whole frps process with a single crafted request. Upgrade to frp 0.70.1, or disable the SSH Tunnel Gateway if you cannot upgrade.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.7 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0052, the 44th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:50 UTC First seen by agentprime
- 31 Oct 2026, 14:50 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-26gq-p25f-99cp
- OSV: GHSA-26gq-p25f-99cp
- github.com/fatedier/frp/security/advisories/GHSA-26gq-p25f-99cp
- github.com/fatedier/frp/pull/5428
- github.com/fatedier/frp/commit/7dc7be930e2452ae93fd32f2a77f8c6fcd0b652b
- github.com/fatedier/frp
- github.com/fatedier/frp/releases/tag/v0.70.1