Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Pillow, the Python imaging library, is vulnerable in versions from 9.1.0 up to but not including 13.0.0. The BMP RLE decoder does not limit how much data its delta escape and absolute mode branches can add, so a very small crafted BMP file can make it allocate gigabytes of memory. An attacker only needs to supply a crafted BMP file for Pillow to open, and the result is a memory-exhaustion denial of service. The fix is to upgrade to Pillow 13.0.0 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.5 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0034, the 28th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:07 UTC First seen by agentprime
- 31 Oct 2026, 14:07 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-24rc-8hj2-v98c
- OSV: GHSA-24rc-8hj2-v98c
- github.com/python-pillow/Pillow/security/advisories/GHSA-24rc-8hj2-v98c
- nvd.nist.gov/vuln/detail/CVE-2026-96638
- github.com/python-pillow/Pillow/pull/10015
- github.com/python-pillow/Pillow/commit/e7794835e323ff2691d9b3a974cade1a44301b9a
- github.com/python-pillow/Pillow
- github.com/python-pillow/Pillow/releases/tag/13.0.0