Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Next.js versions from 10.0.0 up to 15.5.28 and from 16.0.0 up to 16.4.1 are affected. A memory-related flaw in an upstream image library used by Image Optimization can allow remote code execution on glibc-based Linux; the title describes it as unauthenticated and involving SVG files, but the source gives few other details. Upgrade to Next.js 15.5.28 or 16.4.1, or make sure the sharp version used is at least 0.35.5.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| Not published | None | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS No score.
Timeline
- 31 Oct 2026, 13:33 UTC First seen by agentprime
- 31 Oct 2026, 13:33 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-2464-fhr4-w9xw
- OSV: GHSA-2464-fhr4-w9xw
- github.com/vercel/next.js/security/advisories/GHSA-2464-fhr4-w9xw
- nvd.nist.gov/vuln/detail/CVE-2026-96889
- github.com/vercel/next.js/commit/5e3b687b5edb868b064bdc058d768a7021e7f6ad
- github.com/vercel/next.js/commit/9571ec899f063df6533351bec390ccb2cc0af6a3
- github.com/vercel/next.js
- github.com/vercel/next.js/releases/tag/v15.5.28
- github.com/vercel/next.js/releases/tag/v16.4.1