Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The openapi-generator-online package (Maven org.openapitools:openapi-generator-online) is vulnerable in versions before 5.1.0. On Unix-like systems, a local user on the same machine can race the creation of a temporary directory used during code generation, and then append to generated files, which can lead to local privilege escalation. Upgrade to version 5.1.0 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.3 | Critical | 3.1 | CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0035, the 28th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:20 UTC First seen by agentprime
- 31 Oct 2026, 14:20 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-23x4-m842-fmwf
- OSV: GHSA-23x4-m842-fmwf
- github.com/OpenAPITools/openapi-generator/security/advisories/GHSA-23x4-m842-fmwf
- github.com/swagger-api/swagger-codegen/security/advisories/GHSA-pc22-3g76-gm6j
- nvd.nist.gov/vuln/detail/CVE-2021-21428
- github.com/OpenAPITools/openapi-generator/pull/8788
- github.com/OpenAPITools/openapi-generator
- github.com/OpenAPITools/openapi-generator/blob/c6530519975341d7784a252132b2f0854f488901/modules/openapi-generator-online/src/main/java/org/openapitools/codegen/online/service/Generator.java#L184-L187