Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Docker (github.com/docker/docker) versions from 1.12.0 before 20.10.24, and 23.0.0 before 23.0.3, are affected when Swarm encrypted overlay networks are used. An attacker who can send VXLAN traffic to a node can inject arbitrary Ethernet frames into an encrypted overlay network, which can cause denial of service and may let them bypass stateful firewall rules. Upgrade to 20.10.24 or 23.0.3. As a workaround, close the VXLAN port (UDP 4789 by default) to incoming traffic at the network boundary, and make sure the xt_u32 kernel module is available on all Swarm nodes.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.026, the 85th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:16 UTC First seen by agentprime
- 31 Oct 2026, 14:16 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-232p-vwff-86mp
- OSV: GHSA-232p-vwff-86mp
- github.com/moby/libnetwork/security/advisories/GHSA-gvm4-2qqg-m333
- github.com/moby/moby/security/advisories/GHSA-232p-vwff-86mp
- github.com/moby/moby/security/advisories/GHSA-33pg-m6jh-5237
- github.com/moby/moby/security/advisories/GHSA-6wrf-mxfj-pf5p
- github.com/moby/moby/security/advisories/GHSA-vwm3-crmr-xfxw
- nvd.nist.gov/vuln/detail/CVE-2023-28840
- github.com/moby/moby/issues/43382
- github.com/moby/moby/pull/45118
- github.com/moby/moby