Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
WebDyne versions from 3.007 before 3.022 for Perl are affected. A remote attacker can use path traversal in the PSGI API route fallback to run the embedded Perl in any .psp file the server can read, including files outside the document root. Upgrade WebDyne to version 3.022 or later. The source gives no workaround.
Not analysed yet
We haven’t published our own analysis of this CVE. If a person reviews it, this page will say what’s affected and what has to be true for it to matter.
Severity and exploitation
No source has published a CVSS score for this record yet.
- CISA KEV Not listed.
- EPSS 0.0025, the 16th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:33 UTC Confirmed by the CVE List
- 31 Oct 2026, 14:39 UTC First seen by agentprime
- 31 Oct 2026, 15:16 UTC Confirmed by NVD