# Hybrid Encapsulation from Seed Panics on Short Seed

Advisory record · `RUSTSEC-2026-0330`

- **Identifiers:** `RUSTSEC-2026-0330`
- **State:** Confirmed
- **Severity:** CVSS 4.0, no score published
- **Critical:** No
- **Published:** 28 Sept 2026
- **Updated:** 7 Oct 2026
- **Reviewed by a person:** No

Published by OSV at 28 Sept 2026, 12:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `libcrux-kem` (crates.io): affected `>=0.0.0-0, <0.0.10`; fixed in `0.0.10`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> libcrux-kem versions before 0.0.10 can panic when the PublicKey::encapsulate_derand function is called with a seed shorter than 32 bytes on a hybrid KEM public key of type WingKemDraft06 or X25519MlKem768Draft06. An attacker would need to control the seed value used for encapsulation, which causes the application to panic. Upgrade libcrux-kem to version 0.0.10, and do not take the encapsulation seed from an untrusted source.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- Score not published, CVSS 4.0: `CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`, from OSV

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:24 UTC: First seen by agentprime
- 31 Oct 2026, 14:24 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/RUSTSEC-2026-0330)

## Sources

- [OSV: RUSTSEC-2026-0330](https://osv.dev/vulnerability/RUSTSEC-2026-0330)
- <https://crates.io/crates/libcrux-kem>
- <https://rustsec.org/advisories/RUSTSEC-2026-0330.html>
- <https://github.com/celabshq/libcrux/pull/1595>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/RUSTSEC-2026-0330>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/RUSTSEC-2026-0330/>. Everything for agents: <https://agentprime.io/llms.txt>.
