# Stack overflow on deeply nested LaTeX input

Advisory record · `RUSTSEC-2026-0311`

- **Identifiers:** `RUSTSEC-2026-0311`
- **State:** Confirmed
- **Severity:** No CVSS score
- **Critical:** No
- **Published:** 27 Sept 2026
- **Updated:** 28 Sept 2026
- **Reviewed by a person:** No

Published by OSV at 27 Sept 2026, 12:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `latex-rust` (crates.io): affected `>=0.0.0-0, <1.0.5`; fixed in `1.0.5`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Versions of latex-rust before 1.0.5 recurse once per level of nesting in the parser and layout engine, with no limit. An attacker who can supply LaTeX input to a program that renders it can crash the process with a short string, such as a few thousand nested braces or fractions, because the stack overflow aborts rather than panics. Upgrade to latex-rust 1.0.5, which caps nesting at 32 levels and returns an error for deeper input; note that 1.0.5 also includes rendering changes from 2.0.0, so output may differ.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

No source has published a CVSS score for this record yet.

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:24 UTC: First seen by agentprime
- 31 Oct 2026, 14:24 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/RUSTSEC-2026-0311)

## Sources

- [OSV: RUSTSEC-2026-0311](https://osv.dev/vulnerability/RUSTSEC-2026-0311)
- <https://crates.io/crates/latex-rust>
- <https://rustsec.org/advisories/RUSTSEC-2026-0311.html>
- <https://github.com/jscarr64/LaTeX-Rust/pull/10>
- <https://github.com/jscarr64/LaTeX-Rust/releases/tag/v1.0.5>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/RUSTSEC-2026-0311>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/RUSTSEC-2026-0311/>. Everything for agents: <https://agentprime.io/llms.txt>.
