# vLLM through 0.29.0 contains a memory corruption vulnerability in the Triton \_bincount_kernel where prompt token IDs index the penalty prompt-presence bitset without bounds checking against vocabul...

Advisory record · `PYSEC-2026-3999`

- **Identifiers:** `PYSEC-2026-3999` · `CVE-2026-93841`
- **State:** Confirmed
- **Severity:** CVSS 6.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-129](https://cwe.mitre.org/data/definitions/129.html)
- **Tags:** [CWE-129](https://agentprime.io/advisories/tag/cwe-129.md)
- **Published:** 18 Sept 2026
- **Updated:** 29 Sept 2026
- **Reviewed by a person:** No

Published by OSV at 18 Sept 2026, 20:17 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `vllm` (PyPI): affected `<0.30.0`; fixed in `0.30.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> vLLM versions through 0.29.0 have a memory corruption flaw in the Triton \_bincount_kernel, where prompt token IDs are used to index the penalty prompt-presence bitset without a bounds check against vocabulary size. An attacker able to submit multimodal audio requests can use tokens equal to the vocabulary size to cause out-of-bounds writes, which corrupt other concurrent requests' sampler state and change repetition penalty behavior. Upgrade to vLLM 0.30.0 or later.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.3 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0024, the 14th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:09 UTC: First seen by agentprime
- 31 Oct 2026, 14:09 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/PYSEC-2026-3999)

## Sources

- [OSV: PYSEC-2026-3999](https://osv.dev/vulnerability/PYSEC-2026-3999)
- <https://github.com/vllm-project/vllm/blob/v0.29.0/vllm/v1/worker/gpu/sample/penalties.py#L241-L255>
- <https://github.com/vllm-project/vllm/blob/v0.29.0/vllm/v1/worker/gpu/sample/penalties.py#L33-L37>
- <https://www.vulncheck.com/advisories/vllm-through-0.29.0-adjacent-request-sampler-state-corruption-via-unvalidated-prompt-token-ids>
- <https://github.com/vllm-project/vllm/pull/49081>
- <https://github.com/vllm-project/vllm>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/PYSEC-2026-3999>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/PYSEC-2026-3999/>. Everything for agents: <https://agentprime.io/llms.txt>.
