# vLLM before 0.29.0 validates allowed_token_ids against tokenizer length instead of model output logits width in SamplingParams.\_validate_allowed_token_ids(). Attackers can supply token IDs above th...

Advisory record · `PYSEC-2026-3998`

- **Identifiers:** `PYSEC-2026-3998` · `CVE-2026-93840`
- **State:** Confirmed
- **Severity:** CVSS 6.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-129](https://cwe.mitre.org/data/definitions/129.html)
- **Tags:** [CWE-129](https://agentprime.io/advisories/tag/cwe-129.md)
- **Published:** 18 Sept 2026
- **Updated:** 29 Sept 2026
- **Reviewed by a person:** No

Published by OSV at 18 Sept 2026, 20:17 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `vllm` (PyPI): affected `<0.29.0`; fixed in `0.29.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> vLLM versions before 0.29.0 validate allowed_token_ids against the tokenizer length rather than the model's output logits width. An attacker who can send requests can supply token IDs above the output vocabulary that pass validation, which can corrupt GPU logits state and let concurrent requests sample tokens outside their allowlists. Upgrade vllm to 0.29.0 or later.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.3 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0025, the 15th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:09 UTC: First seen by agentprime
- 31 Oct 2026, 14:09 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/PYSEC-2026-3998)

## Sources

- [OSV: PYSEC-2026-3998](https://osv.dev/vulnerability/PYSEC-2026-3998)
- <https://github.com/vllm-project/vllm/blob/v0.28.0/vllm/sampling_params.py#L881-L903>
- <https://github.com/vllm-project/vllm/blob/v0.28.0/vllm/v1/worker/gpu/sample/logit_bias.py#L179-L191>
- <https://www.vulncheck.com/advisories/vllm-before-0.29.0-cross-request-logits-corruption-via-allowed-token-ids>
- <https://github.com/vllm-project/vllm/commit/5b0e5b69ac1a3884a6479c9537789c95263cc804>
- <https://github.com/vllm-project/vllm/pull/49080>
- <https://github.com/vllm-project/vllm>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/PYSEC-2026-3998>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/PYSEC-2026-3998/>. Everything for agents: <https://agentprime.io/llms.txt>.
