# Fedify has an incomplete SSRF mitigation after GHSA-p9cg-vqcc-grcx: validatePublicUrl allows special-use IPv4 ranges

Advisory record · `GHSA-xw9q-2mv6-9fr8`

- **Identifiers:** `GHSA-xw9q-2mv6-9fr8` · `CVE-2026-50131`
- **State:** Confirmed
- **Severity:** CVSS 8.6 High
- **Critical:** No
- **Weakness (CWE):** [CWE-918](https://cwe.mitre.org/data/definitions/918.html) · [CWE-1286](https://cwe.mitre.org/data/definitions/1286.html) · [CWE-1389](https://cwe.mitre.org/data/definitions/1389.html)
- **Tags:** [Server-side request forgery (SSRF)](https://agentprime.io/advisories/tag/ssrf.md) · [CWE-1286](https://agentprime.io/advisories/tag/cwe-1286.md) · [CWE-1389](https://agentprime.io/advisories/tag/cwe-1389.md)
- **Published:** 14 Jul 2026
- **Updated:** 28 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 14 Jul 2026, 18:15 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@fedify/fedify` (npm): affected `>=0.11.2, <1.9.12 || >=1.10.0, <1.10.11 || >=2.0.0, <2.0.19 || >=2.1.0, <2.1.15 || >=2.2.0, <2.2.4`; fixed in `1.9.12`, `1.10.11`, `2.0.19`, `2.1.15`, `2.2.4`
- `@fedify/vocab-runtime` (npm): affected `<2.0.19 || >=2.1.0, <2.1.15 || >=2.2.0, <2.2.4`; fixed in `2.0.19`, `2.1.15`, `2.2.4`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.6 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0035, the 28th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 14 Jul 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-xw9q-2mv6-9fr8](https://github.com/advisories/GHSA-xw9q-2mv6-9fr8)
- [OSV: GHSA-xw9q-2mv6-9fr8](https://osv.dev/vulnerability/GHSA-xw9q-2mv6-9fr8)
- <https://github.com/fedify-dev/fedify/security/advisories/GHSA-xw9q-2mv6-9fr8>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-50131>
- <https://github.com/fedify-dev/fedify>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-xw9q-2mv6-9fr8>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-xw9q-2mv6-9fr8/>. Everything for agents: <https://agentprime.io/llms.txt>.
