# Apache Ranger policy engine incorrectly matches paths in certain conditions

Advisory record · `GHSA-xv7x-x6wr-xx7g`

- **Identifiers:** `GHSA-xv7x-x6wr-xx7g` · `CVE-2016-8746`
- **State:** Confirmed
- **Severity:** CVSS 5.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-426](https://cwe.mitre.org/data/definitions/426.html)
- **Tags:** [CWE-426](https://agentprime.io/advisories/tag/cwe-426.md)
- **Published:** 17 Oct 2018
- **Updated:** 16 Feb 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 17 Oct 2018, 17:22 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.apache.ranger:ranger-plugins-common` (Maven): affected `<0.6.3`; fixed in `0.6.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.9 Medium, CVSS 3.0: `CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.027, the 86th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 17 Oct 2018. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-xv7x-x6wr-xx7g](https://github.com/advisories/GHSA-xv7x-x6wr-xx7g)
- [OSV: GHSA-xv7x-x6wr-xx7g](https://osv.dev/vulnerability/GHSA-xv7x-x6wr-xx7g)
- <https://nvd.nist.gov/vuln/detail/CVE-2016-8746>
- <https://github.com/apache/ranger/commit/2fcd7f7cc175c0734443638b99c359e24c0f88ff>
- <https://cwiki.apache.org/confluence/display/RANGER/Vulnerabilities+found+in+Ranger>
- <https://github.com/advisories/GHSA-xv7x-x6wr-xx7g>
- <http://www.securityfocus.com/bid/95998>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-xv7x-x6wr-xx7g>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-xv7x-x6wr-xx7g/>. Everything for agents: <https://agentprime.io/llms.txt>.
