# websocket-driver: Message corruption via abuse of protocol length headers

Advisory record · `GHSA-xv26-6w52-cph6`

- **Identifiers:** `GHSA-xv26-6w52-cph6` · `CVE-2026-54466`
- **State:** Confirmed
- **Severity:** CVSS 9.2 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-130](https://cwe.mitre.org/data/definitions/130.html)
- **Tags:** [CWE-130](https://agentprime.io/advisories/tag/cwe-130.md)
- **Published:** 15 Jul 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 15 Jul 2026, 22:07 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.2: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `websocket-driver` (npm): affected `<0.7.5`; fixed in `0.7.5`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.2 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:H/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0038, the 32nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 15 Jul 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-xv26-6w52-cph6](https://github.com/advisories/GHSA-xv26-6w52-cph6)
- [OSV: GHSA-xv26-6w52-cph6](https://osv.dev/vulnerability/GHSA-xv26-6w52-cph6)
- <https://github.com/faye/websocket-driver-node/security/advisories/GHSA-xv26-6w52-cph6>
- <https://github.com/faye/websocket-driver-node>
- <https://github.com/faye/websocket-driver-node/releases/tag/0.7.5>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-xv26-6w52-cph6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-xv26-6w52-cph6/>. Everything for agents: <https://agentprime.io/llms.txt>.
