# Overflow/crash in \`tf.range\`

Advisory record · `GHSA-xrqm-fpgr-6hhx`

- **Identifiers:** `GHSA-xrqm-fpgr-6hhx` · `BIT-tensorflow-2021-41202` · `CVE-2021-41202` · `PYSEC-2021-395` · `PYSEC-2021-612` · `PYSEC-2021-810`
- **State:** Confirmed
- **Severity:** CVSS 5.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-681](https://cwe.mitre.org/data/definitions/681.html)
- **Tags:** [CWE-681](https://agentprime.io/advisories/tag/cwe-681.md)
- **Published:** 10 Nov 2021
- **Updated:** 8 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 10 Nov 2021, 19:13 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `tensorflow` (PyPI): affected `>=2.6.0, <2.6.1 || >=2.5.0, <2.5.2 || <2.4.4`; fixed in `2.6.1`, `2.5.2`, `2.4.4`
- `tensorflow-cpu` (PyPI): affected `>=2.6.0, <2.6.1 || >=2.5.0, <2.5.2 || <2.4.4`; fixed in `2.6.1`, `2.5.2`, `2.4.4`
- `tensorflow-gpu` (PyPI): affected `>=2.6.0, <2.6.1 || >=2.5.0, <2.5.2 || <2.4.4`; fixed in `2.6.1`, `2.5.2`, `2.4.4`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.5 Medium, CVSS 3.1: `CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0021, the 11th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 10 Nov 2021. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-xrqm-fpgr-6hhx](https://github.com/advisories/GHSA-xrqm-fpgr-6hhx)
- [OSV: GHSA-xrqm-fpgr-6hhx](https://osv.dev/vulnerability/GHSA-xrqm-fpgr-6hhx)
- <https://github.com/tensorflow/tensorflow/security/advisories/GHSA-xrqm-fpgr-6hhx>
- <https://nvd.nist.gov/vuln/detail/CVE-2021-41202>
- <https://github.com/tensorflow/tensorflow/issues/46889>
- <https://github.com/tensorflow/tensorflow/issues/46912>
- <https://github.com/tensorflow/tensorflow/commit/1b0e0ec27e7895b9985076eab32445026ae5ca94>
- <https://github.com/tensorflow/tensorflow/commit/6d94002a09711d297dbba90390d5482b76113899>
- <https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-612.yaml>
- <https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-810.yaml>
- <https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-395.yaml>
- <https://github.com/tensorflow/tensorflow>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-xrqm-fpgr-6hhx>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-xrqm-fpgr-6hhx/>. Everything for agents: <https://agentprime.io/llms.txt>.
