# Poetry before v1.1.9 contains Untrusted Search Path

Advisory record · `GHSA-xr2c-5w89-63pv`

- **Identifiers:** `GHSA-xr2c-5w89-63pv` · `CVE-2022-26184` · `PYSEC-2022-234`
- **State:** Confirmed
- **Severity:** CVSS 9.8 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-426](https://cwe.mitre.org/data/definitions/426.html)
- **Tags:** [CWE-426](https://agentprime.io/advisories/tag/cwe-426.md)
- **Published:** 23 Mar 2022
- **Updated:** 21 Oct 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 23 Mar 2022, 00:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.8: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `poetry` (PyPI): affected `<1.1.9`; fixed in `1.1.9`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.8 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.018, the 79th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 23 Mar 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-xr2c-5w89-63pv](https://github.com/advisories/GHSA-xr2c-5w89-63pv)
- [OSV: GHSA-xr2c-5w89-63pv](https://osv.dev/vulnerability/GHSA-xr2c-5w89-63pv)
- <https://nvd.nist.gov/vuln/detail/CVE-2022-26184>
- <https://github.com/python-poetry/poetry-core/pull/205/commits/fa9cb6f358ae840885c700f954317f34838caba7>
- <https://github.com/python-poetry/poetry-core/commit/1e1a109a1009daaab2367ce90c997f0cbbb0c1d1>
- <https://github.com/advisories/GHSA-xr2c-5w89-63pv>
- <https://github.com/pypa/advisory-database/tree/main/vulns/poetry/PYSEC-2022-234.yaml>
- <https://github.com/python-poetry>
- <https://github.com/python-poetry/poetry/releases/tag/1.1.9>
- <https://www.sonarsource.com/blog/securing-developer-tools-package-managers>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-xr2c-5w89-63pv>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-xr2c-5w89-63pv/>. Everything for agents: <https://agentprime.io/llms.txt>.
