# Poly1305 panics or computes a wrong tag on attacker-chosen messages of 64 bytes or more

Advisory record · `GHSA-xr22-8pqp-gwfh`

- **Identifiers:** `GHSA-xr22-8pqp-gwfh` · `RUSTSEC-2026-0337`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Published:** 9 Oct 2026
- **Updated:** 12 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 9 Oct 2026, 12:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `ic-cipher` (crates.io): affected `>=0.2.5, <0.2.20`; fixed in `0.2.20`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Poly1305 and ChaCha20-Poly1305 in ic-cipher versions 0.2.5 through 0.2.19 can panic or compute a wrong authentication tag on messages of 64 bytes or more. An attacker who can deliver a ChaCha20-Poly1305 ciphertext for opening can trigger the panic, which ends the process under panic = "abort" in builds with overflow checks on, and no key is needed. Upgrade ic-cipher to 0.2.20.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from OSV

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:24 UTC: First seen by agentprime
- 31 Oct 2026, 14:24 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/RUSTSEC-2026-0337)

## Sources

- [GitHub Advisory Database: GHSA-xr22-8pqp-gwfh](https://github.com/advisories/GHSA-xr22-8pqp-gwfh)
- [OSV: GHSA-xr22-8pqp-gwfh](https://osv.dev/vulnerability/GHSA-xr22-8pqp-gwfh)
- <https://crates.io/crates/ic-cipher>
- <https://rustsec.org/advisories/RUSTSEC-2026-0337.html>
- <https://github.com/nervosys/IronCrypto/commit/a8160a18b5c66288f05dc62f5ea2159c687b9416>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-xr22-8pqp-gwfh>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-xr22-8pqp-gwfh/>. Everything for agents: <https://agentprime.io/llms.txt>.
