# rails-ujs vulnerable to DOM Based Cross-site Scripting contenteditable HTML Elements

Advisory record · `GHSA-xp5h-f8jf-rc8q`

- **Identifiers:** `GHSA-xp5h-f8jf-rc8q` · `CVE-2023-23913`
- **State:** Confirmed
- **Severity:** CVSS 6.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md)
- **Published:** 9 Jun 2023
- **Updated:** 9 Jan 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 9 Jun 2023, 22:41 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `actionview` (RubyGems): affected `>=5.1.0, <6.1.7.3 || >=7.0.0, <7.0.4.3`; fixed in `6.1.7.3`, `7.0.4.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0064, the 50th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 9 Jun 2023. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-xp5h-f8jf-rc8q](https://github.com/advisories/GHSA-xp5h-f8jf-rc8q)
- [OSV: GHSA-xp5h-f8jf-rc8q](https://osv.dev/vulnerability/GHSA-xp5h-f8jf-rc8q)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-23913>
- <https://github.com/rails/rails/commit/5037a13614d71727af8a175063bcf6ba1a74bdbd>
- <https://github.com/rails/rails/commit/73009ea59a811b28e8ec2a9c9bc24635aa891214>
- <https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1033263>
- <https://discuss.rubyonrails.org/t/cve-2023-23913-dom-based-cross-site-scripting-in-rails-ujs-for-contenteditable-html-elements/82468>
- <https://github.com/rails/rails>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/actionview/CVE-2023-23913.yml>
- <https://security.netapp.com/advisory/ntap-20240605-0007>
- <https://www.debian.org/security/2023/dsa-5389>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-xp5h-f8jf-rc8q>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-xp5h-f8jf-rc8q/>. Everything for agents: <https://agentprime.io/llms.txt>.
