# Auth.js: getToken() throws an uncaught exception on malformed Bearer authorization headers

Advisory record · `GHSA-xmf8-cvqr-rfgj`

- **Identifiers:** `GHSA-xmf8-cvqr-rfgj` · `CVE-2026-73418`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html) · [CWE-248](https://cwe.mitre.org/data/definitions/248.html)
- **Tags:** [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md) · [CWE-248](https://agentprime.io/advisories/tag/cwe-248.md)
- **Published:** 23 Jul 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 23 Jul 2026, 14:42 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@auth/core` (npm): affected `>=0.1.0, <0.41.3`; fixed in `0.41.3`
- `next-auth` (npm): affected `>=5.0.0-beta.0, <5.0.0-beta.32 || >=4.0.6, <4.24.15`; fixed in `5.0.0-beta.32`, `4.24.15`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0088, the 59th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 23 Jul 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-xmf8-cvqr-rfgj](https://github.com/advisories/GHSA-xmf8-cvqr-rfgj)
- [OSV: GHSA-xmf8-cvqr-rfgj](https://osv.dev/vulnerability/GHSA-xmf8-cvqr-rfgj)
- <https://github.com/nextauthjs/next-auth/security/advisories/GHSA-xmf8-cvqr-rfgj>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-73418>
- <https://github.com/nextauthjs/next-auth/pull/13467>
- <https://github.com/nextauthjs/next-auth/pull/13469>
- <https://github.com/nextauthjs/next-auth/commit/5bca2399a79ba8d116ca5179b4b1ebcd152e7f05>
- <https://github.com/nextauthjs/next-auth/commit/e707770f00c52b3479e43422b0200b059149ed53>
- <https://github.com/nextauthjs/next-auth>
- <https://github.com/nextauthjs/next-auth/releases/tag/@auth/core@0.41.3>
- <https://github.com/nextauthjs/next-auth/releases/tag/next-auth@4.24.15>
- <https://github.com/nextauthjs/next-auth/releases/tag/next-auth@5.0.0-beta.32>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-xmf8-cvqr-rfgj>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-xmf8-cvqr-rfgj/>. Everything for agents: <https://agentprime.io/llms.txt>.
