# mcp-contextforge-gateway has RestrictedPython sandbox bypass via getattr builtin in python_sandbox_server

Advisory record · `GHSA-xm98-3vcf-fph7`

- **Identifiers:** `GHSA-xm98-3vcf-fph7` · `CVE-2026-53710` · `PYSEC-2026-3862`
- **State:** Confirmed
- **Severity:** CVSS 10.0 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-94](https://cwe.mitre.org/data/definitions/94.html) · [CWE-693](https://cwe.mitre.org/data/definitions/693.html)
- **Tags:** [Code injection](https://agentprime.io/advisories/tag/code-injection.md) · [CWE-693](https://agentprime.io/advisories/tag/cwe-693.md)
- **Published:** 24 Aug 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 Aug 2026, 19:20 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 10.0: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `mcp-contextforge-gateway` (PyPI): affected `<1.0.2`; fixed in `1.0.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Versions of mcp-contextforge-gateway before 1.0.2 contain a sandbox bypass in the python_sandbox_server component, where raw getattr is exposed to RestrictedPython code, allowing arbitrary Python execution. An attacker who can reach the sandbox's HTTP/SSE endpoint without authentication can run operating system commands with the privileges of the server process. Upgrade to version 1.0.2 or later; if the sandbox server cannot be upgraded, do not expose its HTTP transport to untrusted clients.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 10.0 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.011, the 66th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:10 UTC: First seen by agentprime
- 31 Oct 2026, 14:10 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-xm98-3vcf-fph7)

## Sources

- [GitHub Advisory Database: GHSA-xm98-3vcf-fph7](https://github.com/advisories/GHSA-xm98-3vcf-fph7)
- [OSV: GHSA-xm98-3vcf-fph7](https://osv.dev/vulnerability/GHSA-xm98-3vcf-fph7)
- <https://github.com/IBM/mcp-context-forge/security/advisories/GHSA-xm98-3vcf-fph7>
- <https://github.com/IBM/mcp-context-forge/commit/63a2900e6301b9c8a483a38d3737a1beb3a7ce89>
- <https://github.com/IBM/mcp-context-forge>
- <https://github.com/IBM/mcp-context-forge/releases#release-v1.0.2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-xm98-3vcf-fph7>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-xm98-3vcf-fph7/>. Everything for agents: <https://agentprime.io/llms.txt>.
