# Nokogiri Improperly Handles Unexpected Data Type

Advisory record · `GHSA-xh29-r2w5-wx8m`

- **Identifiers:** `GHSA-xh29-r2w5-wx8m` · `CVE-2022-29181`
- **State:** Confirmed
- **Severity:** CVSS 8.2 High
- **Critical:** No
- **Weakness (CWE):** [CWE-241](https://cwe.mitre.org/data/definitions/241.html) · [CWE-843](https://cwe.mitre.org/data/definitions/843.html)
- **Tags:** [Memory corruption](https://agentprime.io/advisories/tag/memory-corruption.md) · [CWE-241](https://agentprime.io/advisories/tag/cwe-241.md)
- **Published:** 23 May 2022
- **Updated:** 27 May 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 23 May 2022, 23:15 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `nokogiri` (RubyGems): affected `<1.13.6`; fixed in `1.13.6`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.2 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.032, the 88th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 23 May 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-xh29-r2w5-wx8m](https://github.com/advisories/GHSA-xh29-r2w5-wx8m)
- [OSV: GHSA-xh29-r2w5-wx8m](https://osv.dev/vulnerability/GHSA-xh29-r2w5-wx8m)
- <https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-xh29-r2w5-wx8m>
- <https://nvd.nist.gov/vuln/detail/CVE-2022-29181>
- <https://github.com/sparklemotion/nokogiri/commit/83cc451c3f29df397caa890afc3b714eae6ab8f7>
- <https://github.com/sparklemotion/nokogiri/commit/db05ba9a1bd4b90aa6c76742cf6102a7c7297267>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/nokogiri/CVE-2022-29181.yml>
- <https://github.com/sparklemotion/nokogiri>
- <https://github.com/sparklemotion/nokogiri/releases/tag/v1.13.6>
- <https://security.gentoo.org/glsa/202208-29>
- <https://securitylab.github.com/advisories/GHSL-2022-031_GHSL-2022-032_Nokogiri>
- <https://support.apple.com/kb/HT213532>
- <http://seclists.org/fulldisclosure/2022/Dec/23>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-xh29-r2w5-wx8m>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-xh29-r2w5-wx8m/>. Everything for agents: <https://agentprime.io/llms.txt>.
