# Moodle Lesson activity password bypass through PHP loose comparison

Advisory record · `GHSA-xfv7-h2qg-rjm7`

- **Identifiers:** `GHSA-xfv7-h2qg-rjm7` · `BIT-moodle-2024-45691` · `CVE-2024-45691` · `PKSA-y22b-yrq9-2frq`
- **State:** Confirmed
- **Severity:** CVSS 5.4 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-285](https://cwe.mitre.org/data/definitions/285.html) · [CWE-289](https://cwe.mitre.org/data/definitions/289.html)
- **Tags:** [Broken access control](https://agentprime.io/advisories/tag/access-control.md) · [CWE-289](https://agentprime.io/advisories/tag/cwe-289.md)
- **Published:** 20 Nov 2024
- **Updated:** 3 Jun 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Nov 2024, 12:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `moodle/moodle` (Packagist): affected `<4.1.13 || >=4.2.0-beta, <4.2.10 || >=4.3.0-beta, <4.3.7 || >=4.4.0-beta, <4.4.3`; fixed in `4.1.13`, `4.2.10`, `4.3.7`, `4.4.3`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Moodle versions before 4.1.13, from 4.2.0-beta before 4.2.10, from 4.3.0-beta before 4.3.7, and from 4.4.0-beta before 4.4.3 are affected. In the Lesson activity, a password check using loose comparison can be bypassed when the password is set to a "magic hash" value. Upgrade to 4.1.13, 4.2.10, 4.3.7, 4.4.3, or later.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.4 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0041, the 35th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:27 UTC: First seen by agentprime
- 31 Oct 2026, 14:27 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-xfv7-h2qg-rjm7)

## Sources

- [GitHub Advisory Database: GHSA-xfv7-h2qg-rjm7](https://github.com/advisories/GHSA-xfv7-h2qg-rjm7)
- [OSV: GHSA-xfv7-h2qg-rjm7](https://osv.dev/vulnerability/GHSA-xfv7-h2qg-rjm7)
- <https://nvd.nist.gov/vuln/detail/CVE-2024-45691>
- <https://github.com/moodle/moodle/commit/3fc1073d304f660d2552b591c5fb92547ed01e92>
- <https://bugzilla.redhat.com/show_bug.cgi?id=2309940>
- <https://github.com/moodle/moodle>
- <https://moodle.org/mod/forum/discuss.php?d=461897#p1854494>
- <https://moodle.org/security>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-xfv7-h2qg-rjm7>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-xfv7-h2qg-rjm7/>. Everything for agents: <https://agentprime.io/llms.txt>.
