# YesWiki has stored XSS in Bazar form-field templates via unescaped field.label / field.hint (|raw('html'))

Advisory record · `GHSA-xc7j-3g8q-9vh4`

- **Identifiers:** `GHSA-xc7j-3g8q-9vh4` · `CVE-2026-52772` · `PKSA-p24r-4kjm-tm2m`
- **State:** Confirmed
- **Severity:** CVSS 5.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html) · [CWE-116](https://cwe.mitre.org/data/definitions/116.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md) · [CWE-116](https://agentprime.io/advisories/tag/cwe-116.md)
- **Published:** 9 Jul 2026
- **Updated:** 9 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 9 Jul 2026, 21:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `yeswiki/yeswiki` (Packagist): affected `<4.6.6`; fixed in `4.6.6`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Stored cross-site scripting in YesWiki versions before 4.6.6 lets a user who can edit Bazar form definitions inject script through field labels and hints, which then runs for anyone who views a form containing that field. The source describes the attacker as a form editor with the saisie_formulaire permission, which is granted to admins by default. Upgrade to YesWiki 4.6.6 or later, which is listed as the fixed version.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0034, the 27th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:25 UTC: First seen by agentprime
- 31 Oct 2026, 14:25 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-xc7j-3g8q-9vh4)

## Sources

- [GitHub Advisory Database: GHSA-xc7j-3g8q-9vh4](https://github.com/advisories/GHSA-xc7j-3g8q-9vh4)
- [OSV: GHSA-xc7j-3g8q-9vh4](https://osv.dev/vulnerability/GHSA-xc7j-3g8q-9vh4)
- <https://github.com/YesWiki/yeswiki/security/advisories/GHSA-xc7j-3g8q-9vh4>
- <https://github.com/YesWiki/yeswiki/commit/5d1a4d07fecb0706f33e5dfbbe6ff5ef1892b2a7>
- <https://github.com/YesWiki/yeswiki>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-xc7j-3g8q-9vh4>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-xc7j-3g8q-9vh4/>. Everything for agents: <https://agentprime.io/llms.txt>.
