# phpMyAdmin Global variables scope injection vulnerability

Advisory record · `GHSA-x962-w72p-mv7q`

- **Identifiers:** `GHSA-x962-w72p-mv7q` · `CVE-2013-4729` · `PKSA-875g-sgtd-nxx8`
- **State:** Confirmed
- **Severity:** CVSS 5.4 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-621](https://cwe.mitre.org/data/definitions/621.html)
- **Tags:** [CWE-621](https://agentprime.io/advisories/tag/cwe-621.md)
- **Published:** 17 May 2022
- **Updated:** 16 Feb 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 17 May 2022, 05:07 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `phpmyadmin/phpmyadmin` (Packagist): affected `>=4.0, <4.0.4.1`; fixed in `4.0.4.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> phpMyAdmin versions 4.0 up to but not including 4.0.4.1 are vulnerable. A remote attacker with a valid login can send a crafted request to import.php that lets them modify the GLOBALS superglobal array and change the application's configuration. Upgrade to phpMyAdmin 4.0.4.1 or later.

Written 4 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.4 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.011, the 64th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:31 UTC: First seen by agentprime
- 31 Oct 2026, 14:31 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-x962-w72p-mv7q)

## Sources

- [GitHub Advisory Database: GHSA-x962-w72p-mv7q](https://github.com/advisories/GHSA-x962-w72p-mv7q)
- [OSV: GHSA-x962-w72p-mv7q](https://osv.dev/vulnerability/GHSA-x962-w72p-mv7q)
- <https://nvd.nist.gov/vuln/detail/CVE-2013-4729>
- <https://github.com/phpmyadmin/phpmyadmin/commit/012464268420e53a9cd81cbb4a43988d70393c36>
- <https://github.com/phpmyadmin/phpmyadmin>
- <http://www.phpmyadmin.net/home_page/security/PMASA-2013-7.php>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-x962-w72p-mv7q>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-x962-w72p-mv7q/>. Everything for agents: <https://agentprime.io/llms.txt>.
