# Payara Server Full has a Cross-Site Request Forgery vulnerability

Advisory record · `GHSA-x939-7fq5-v9v6`

- **Identifiers:** `GHSA-x939-7fq5-v9v6` · `CVE-2026-12986`
- **State:** Confirmed
- **Severity:** CVSS 7.3 High
- **Critical:** No
- **Weakness (CWE):** [CWE-352](https://cwe.mitre.org/data/definitions/352.html) · [CWE-918](https://cwe.mitre.org/data/definitions/918.html)
- **Tags:** [Cross-site request forgery (CSRF)](https://agentprime.io/advisories/tag/csrf.md) · [Server-side request forgery (SSRF)](https://agentprime.io/advisories/tag/ssrf.md)
- **Published:** 24 Jun 2026
- **Updated:** 25 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 Jun 2026, 15:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `fish.payara.distributions:payara` (Maven): affected `>=4.0.0, <7.2026.6`; fixed in `7.2026.6`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Payara Server Full versions 4.0.0 up to but not including 7.2026.6 are affected by a cross-site request forgery vulnerability in the Admin GUI. An attacker who can get a logged-in administrator to visit a crafted page can cause the admin REST session token to be sent to an attacker-controlled host, then reuse it to take full administrative control and deploy code. Upgrade to Payara Server Full 7.2026.6 or later.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.3 High, CVSS 4.0: `CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:P/S:P/AU:Y/R:U/V:C/RE:M/U:Amber`, from CNA (Payara)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0027, the 19th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:16 UTC: First seen by agentprime
- 31 Oct 2026, 14:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-x939-7fq5-v9v6)

## Sources

- [GitHub Advisory Database: GHSA-x939-7fq5-v9v6](https://github.com/advisories/GHSA-x939-7fq5-v9v6)
- [OSV: GHSA-x939-7fq5-v9v6](https://osv.dev/vulnerability/GHSA-x939-7fq5-v9v6)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-12986>
- <https://github.com/payara/Payara/pull/8229>
- <https://github.com/payara/Payara/commit/be83ab093692bafb09125323f3fdefaeab9cc398>
- <https://docs.payara.fish/community/docs/Release%20Notes/Release%20Notes%207.2026.6.html>
- <https://github.com/payara/Payara>
- <https://github.com/payara/Payara/releases/tag/payara-server-7.2026.6>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-x939-7fq5-v9v6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-x939-7fq5-v9v6/>. Everything for agents: <https://agentprime.io/llms.txt>.
