# simple-git unsafe-operation guard does not block trailer command configuration

Advisory record · `GHSA-x6jw-m9v5-85vh`

- **Identifiers:** `GHSA-x6jw-m9v5-85vh` · `CVE-2026-102828`
- **State:** Confirmed
- **Severity:** CVSS 9.2 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-78](https://cwe.mitre.org/data/definitions/78.html) · [CWE-184](https://cwe.mitre.org/data/definitions/184.html)
- **Tags:** [Command injection](https://agentprime.io/advisories/tag/command-injection.md) · [CWE-184](https://agentprime.io/advisories/tag/cwe-184.md)
- **Published:** 5 Oct 2026
- **Updated:** 6 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 Oct 2026, 23:48 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.2: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `simple-git` (npm): affected `>=3.15.0, <4.0.1`; fixed in `4.0.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The default unsafe-operation plugin in the npm package simple-git, versions 3.15.0 before 4.0.1, does not block Git trailer command configuration. An attacker who can pass untrusted values into instance config options or Git inline configuration arguments can cause a shell command to run with the permissions of the Node.js process. Upgrade to simple-git 4.0.1, the fixed version.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.2 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0037, the 31st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:34 UTC: First seen by agentprime
- 31 Oct 2026, 13:34 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-x6jw-m9v5-85vh)

## Sources

- [GitHub Advisory Database: GHSA-x6jw-m9v5-85vh](https://github.com/advisories/GHSA-x6jw-m9v5-85vh)
- [OSV: GHSA-x6jw-m9v5-85vh](https://osv.dev/vulnerability/GHSA-x6jw-m9v5-85vh)
- <https://github.com/steveukx/git-js/security/advisories/GHSA-x6jw-m9v5-85vh>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-102828>
- <https://github.com/steveukx/git-js/pull/1198>
- <https://github.com/steveukx/git-js/commit/d762810c13b331ff1e5eb24c0b434646d2a8d1b3>
- <https://github.com/steveukx/git-js>
- <https://github.com/steveukx/git-js/releases/tag/simple-git@4.0.1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-x6jw-m9v5-85vh>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-x6jw-m9v5-85vh/>. Everything for agents: <https://agentprime.io/llms.txt>.
