# Missing validation of header name and value in codeigniter4/framework

Advisory record · `GHSA-x5mq-jjr3-vmx6`

- **Identifiers:** `GHSA-x5mq-jjr3-vmx6` · `CVE-2025-24013` · `PKSA-qbjf-dc24-wrff`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-436](https://cwe.mitre.org/data/definitions/436.html)
- **Tags:** [CWE-436](https://agentprime.io/advisories/tag/cwe-436.md)
- **Published:** 21 Jan 2025
- **Updated:** 4 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 21 Jan 2025, 21:13 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `codeigniter4/framework` (Packagist): affected `<4.5.8`; fixed in `4.5.8`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> CodeIgniter4 framework versions before 4.5.8 do not validate header names and values passed to the Header class. An attacker who can supply header input to the application can build malformed headers, which may cause errors or invalid HTTP requests and, in some cases, lead to denial of service if a web application firewall blocks the application's traffic. Upgrade to version 4.5.8 or later. As a workaround, validate header names and values that come from user input before passing them to the Header class.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0051, the 43rd percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:26 UTC: First seen by agentprime
- 31 Oct 2026, 14:26 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-x5mq-jjr3-vmx6)

## Sources

- [GitHub Advisory Database: GHSA-x5mq-jjr3-vmx6](https://github.com/advisories/GHSA-x5mq-jjr3-vmx6)
- [OSV: GHSA-x5mq-jjr3-vmx6](https://osv.dev/vulnerability/GHSA-x5mq-jjr3-vmx6)
- <https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-x5mq-jjr3-vmx6>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-24013>
- <https://github.com/codeigniter4/CodeIgniter4/commit/5f8aa24280fb09947897d6b322bf1f0e038b13b6>
- <https://datatracker.ietf.org/doc/html/rfc7230#section-3.2>
- <https://github.com/advisories/GHSA-wxmh-65f7-jcvw>
- <https://github.com/codeigniter4/CodeIgniter4>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-x5mq-jjr3-vmx6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-x5mq-jjr3-vmx6/>. Everything for agents: <https://agentprime.io/llms.txt>.
