# Hub Package Arbitrary File Overwrite

Advisory record · `GHSA-x5m6-jh4r-34mv`

- **Identifiers:** `GHSA-x5m6-jh4r-34mv` · `CVE-2014-0177`
- **State:** Confirmed
- **Severity:** CVSS 4.4 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-377](https://cwe.mitre.org/data/definitions/377.html)
- **Tags:** [CWE-377](https://agentprime.io/advisories/tag/cwe-377.md)
- **Published:** 15 Feb 2022
- **Updated:** 16 Feb 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 15 Feb 2022, 01:07 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/github/hub` (Go): affected `<1.12.1`; fixed in `1.12.1`
- `hub` (RubyGems): affected `<1.12.1`; fixed in `1.12.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.4 Medium, CVSS 3.1: `CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0039, the 32nd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 15 Feb 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-x5m6-jh4r-34mv](https://github.com/advisories/GHSA-x5m6-jh4r-34mv)
- [OSV: GHSA-x5m6-jh4r-34mv](https://osv.dev/vulnerability/GHSA-x5m6-jh4r-34mv)
- <https://nvd.nist.gov/vuln/detail/CVE-2014-0177>
- <https://github.com/github/hub/commit/016ec99d25b1cb83cb4367e541177aa431beb600>
- <https://github.com/mislav/hub/commit/016ec99d25b1cb83cb4367e541177aa431beb600>
- <https://github.com/mislav/hub>
- <https://github.com/mislav/hub/releases/tag/v1.12.1>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/hub/CVE-2014-0177.yml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-x5m6-jh4r-34mv>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-x5m6-jh4r-34mv/>. Everything for agents: <https://agentprime.io/llms.txt>.
