# vLLM: Responses API bypasses trust_request_chat_template for chat_template_kwargs

Advisory record · `GHSA-x567-49g5-p4cf`

- **Identifiers:** `GHSA-x567-49g5-p4cf` · `CVE-2026-115918` · `PYSEC-2026-4349`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-400](https://cwe.mitre.org/data/definitions/400.html) · [CWE-770](https://cwe.mitre.org/data/definitions/770.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 28 Oct 2026
- **Updated:** 29 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Oct 2026, 21:14 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `vllm` (PyPI): affected `>=0.16.0, <0.32.0`; fixed in `0.32.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The vLLM package (PyPI) versions from 0.16.0 before 0.32.0 are affected: the /v1/responses endpoint accepts request-level chat_template_kwargs and does not apply the --trust-request-chat-template gate that protects other endpoints, so a request-supplied Jinja chat template can be used even when the trust flag is disabled. An authenticated caller who can submit Responses requests can do this, and the source says the related impact is CPU and memory exhaustion from request-controlled templates. Upgrade to vLLM 0.32.0 or later, which is listed as the fixed version.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0035, the 28th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:07 UTC: First seen by agentprime
- 31 Oct 2026, 14:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-x567-49g5-p4cf)

## Sources

- [GitHub Advisory Database: GHSA-x567-49g5-p4cf](https://github.com/advisories/GHSA-x567-49g5-p4cf)
- [OSV: GHSA-x567-49g5-p4cf](https://osv.dev/vulnerability/GHSA-x567-49g5-p4cf)
- <https://github.com/vllm-project/vllm/security/advisories/GHSA-x567-49g5-p4cf>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-115918>
- <https://github.com/vllm-project/vllm/pull/50300>
- <https://github.com/vllm-project/vllm/commit/cff08b461e086523cee8bba5bd3c66d302625134>
- <https://github.com/vllm-project/vllm>
- <https://github.com/vllm-project/vllm/releases/tag/v0.32.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-x567-49g5-p4cf>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-x567-49g5-p4cf/>. Everything for agents: <https://agentprime.io/llms.txt>.
