# Improper Input Validation and Excessive Iteration in Go Facebook Thrift

Advisory record · `GHSA-x4rg-4545-4w7w`

- **Identifiers:** `GHSA-x4rg-4545-4w7w` · `CVE-2019-3564` · `GO-2021-0088`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html) · [CWE-755](https://cwe.mitre.org/data/definitions/755.html) · [CWE-834](https://cwe.mitre.org/data/definitions/834.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md) · [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md) · [CWE-755](https://agentprime.io/advisories/tag/cwe-755.md)
- **Published:** 15 Feb 2022
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 15 Feb 2022, 01:57 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/facebook/fbthrift` (Go): affected `<0.31.1-0.20190225164308-c461c1bd1a3e`; fixed in `0.31.1-0.20190225164308-c461c1bd1a3e`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> github.com/facebook/fbthrift versions before 0.31.1-0.20190225164308-c461c1bd1a3e are affected. A malicious client can send short messages containing containers of unknown-type fields, which take the server a long time to parse and can cause denial of service. Upgrade to 0.31.1-0.20190225164308-c461c1bd1a3e or later.

Written 6 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.020, the 80th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:44 UTC: First seen by agentprime
- 31 Oct 2026, 14:44 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-x4rg-4545-4w7w)

## Sources

- [GitHub Advisory Database: GHSA-x4rg-4545-4w7w](https://github.com/advisories/GHSA-x4rg-4545-4w7w)
- [OSV: GHSA-x4rg-4545-4w7w](https://osv.dev/vulnerability/GHSA-x4rg-4545-4w7w)
- <https://nvd.nist.gov/vuln/detail/CVE-2019-3564>
- <https://github.com/facebook/fbthrift/commit/c461c1bd1a3e130b181aa9c854da3030cd4b5156>
- <https://github.com/facebook/fbthrift>
- <https://lists.apache.org/thread.html/rd0e44e8ef71eeaaa3cf3d1b8b41eb25894372e2995ec908ce7624d26@%3Ccommits.pulsar.apache.org%3E>
- <https://pkg.go.dev/vuln/GO-2021-0088>
- <https://www.facebook.com/security/advisories/cve-2019-3564>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-x4rg-4545-4w7w>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-x4rg-4545-4w7w/>. Everything for agents: <https://agentprime.io/llms.txt>.
