# GeoServer has a Server-Side Request Forgery (SSRF) Vulnerability in its XML Entity Resolution

Advisory record · `GHSA-x4r9-gmw3-hxww`

- **Identifiers:** `GHSA-x4r9-gmw3-hxww` · `CVE-2025-58175`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-20](https://cwe.mitre.org/data/definitions/20.html) · [CWE-611](https://cwe.mitre.org/data/definitions/611.html) · [CWE-918](https://cwe.mitre.org/data/definitions/918.html)
- **Tags:** [XML external entities (XXE)](https://agentprime.io/advisories/tag/xxe.md) · [Server-side request forgery (SSRF)](https://agentprime.io/advisories/tag/ssrf.md) · [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md)
- **Published:** 12 Jun 2026
- **Updated:** 12 Jun 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 12 Jun 2026, 18:23 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.geoserver.web:gs-web-app` (Maven): affected `<2.26.4 || >=2.27.0, <2.27.3`; fixed in `2.26.4`, `2.27.3`
- `org.geoserver:gs-main` (Maven): affected `<2.26.4 || >=2.27.0, <2.27.3`; fixed in `2.26.4`, `2.27.3`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> GeoServer versions below 2.26.4 and from 2.27.0 up to (but not including) 2.27.3, including the gs-web-app and gs-main Maven packages, are vulnerable to unauthenticated Server-Side Request Forgery through XML entity resolution when the ENTITY_RESOLUTION_ALLOWLIST is in use and a proxy base URL is configured. An attacker can cause GeoServer to make requests to unintended locations. Upgrade to 2.26.4, 2.27.3, or later. As a workaround, if the proxy base URL has no path, add a trailing slash to it.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0029, the 21st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:20 UTC: First seen by agentprime
- 31 Oct 2026, 14:20 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-x4r9-gmw3-hxww)

## Sources

- [GitHub Advisory Database: GHSA-x4r9-gmw3-hxww](https://github.com/advisories/GHSA-x4r9-gmw3-hxww)
- [OSV: GHSA-x4r9-gmw3-hxww](https://osv.dev/vulnerability/GHSA-x4r9-gmw3-hxww)
- <https://github.com/geoserver/geoserver/security/advisories/GHSA-x4r9-gmw3-hxww>
- <https://github.com/geoserver/geoserver/pull/8622>
- <https://github.com/geoserver/geoserver>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-x4r9-gmw3-hxww>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-x4r9-gmw3-hxww/>. Everything for agents: <https://agentprime.io/llms.txt>.
