# Auth.js: OAuth state, nonce, and PKCE check cookies are not bound to the provider that created them

Advisory record · `GHSA-x445-f3h2-j279`

- **Identifiers:** `GHSA-x445-f3h2-j279` · `CVE-2026-73419`
- **State:** Confirmed
- **Severity:** CVSS 6.8 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-345](https://cwe.mitre.org/data/definitions/345.html) · [CWE-346](https://cwe.mitre.org/data/definitions/346.html) · [CWE-940](https://cwe.mitre.org/data/definitions/940.html)
- **Tags:** [CWE-345](https://agentprime.io/advisories/tag/cwe-345.md) · [CWE-346](https://agentprime.io/advisories/tag/cwe-346.md) · [CWE-940](https://agentprime.io/advisories/tag/cwe-940.md)
- **Published:** 23 Jul 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 23 Jul 2026, 14:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `@auth/core` (npm): affected `<0.41.3`; fixed in `0.41.3`
- `next-auth` (npm): affected `>=5.0.0-beta.1, <5.0.0-beta.32 || <4.24.15`; fixed in `5.0.0-beta.32`, `4.24.15`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.8 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0025, the 16th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 23 Jul 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-x445-f3h2-j279](https://github.com/advisories/GHSA-x445-f3h2-j279)
- [OSV: GHSA-x445-f3h2-j279](https://osv.dev/vulnerability/GHSA-x445-f3h2-j279)
- <https://github.com/nextauthjs/next-auth/security/advisories/GHSA-x445-f3h2-j279>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-73419>
- <https://github.com/nextauthjs/next-auth/pull/13469>
- <https://github.com/nextauthjs/next-auth/commit/5bca2399a79ba8d116ca5179b4b1ebcd152e7f05>
- <https://github.com/nextauthjs/next-auth/commit/9f7a97fade9b1319bb9ac19fc9828d62e0a2a852>
- <https://github.com/nextauthjs/next-auth>
- <https://github.com/nextauthjs/next-auth/releases/tag/@auth/core@0.41.3>
- <https://github.com/nextauthjs/next-auth/releases/tag/next-auth@4.24.15>
- <https://github.com/nextauthjs/next-auth/releases/tag/next-auth@5.0.0-beta.32>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-x445-f3h2-j279>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-x445-f3h2-j279/>. Everything for agents: <https://agentprime.io/llms.txt>.
