# Browser Use allows bypassing \`allowed_domains\` by putting a decoy domain in http auth username portion of a URL

Advisory record · `GHSA-x39x-9qw5-ghrf`

- **Identifiers:** `GHSA-x39x-9qw5-ghrf` · `CVE-2025-47241` · `PYSEC-2026-300`
- **State:** Confirmed
- **Severity:** CVSS 4.0 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-647](https://cwe.mitre.org/data/definitions/647.html)
- **Tags:** [CWE-647](https://agentprime.io/advisories/tag/cwe-647.md)
- **Published:** 5 May 2025
- **Updated:** 27 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 May 2025, 18:25 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `browser-use` (PyPI): affected `<0.1.45`; fixed in `0.1.45`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The browser-use PyPI package, versions before 0.1.45, has an allowed_domains restriction that can be bypassed. The domain check splits on colons, so a URL with a whitelisted domain placed in the username portion of basic-auth credentials passes the check while the request actually goes to a different host. An attacker who can supply URLs to the agent could reach localhost or internal services that the allowlist was meant to block, and browse outside the permitted domains. Upgrade browser-use to version 0.1.45 or later, which contains the fix.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.0 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:L/A:N`, from CNA (mitre)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0046, the 40th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:07 UTC: First seen by agentprime
- 31 Oct 2026, 14:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-x39x-9qw5-ghrf)

## Sources

- [GitHub Advisory Database: GHSA-x39x-9qw5-ghrf](https://github.com/advisories/GHSA-x39x-9qw5-ghrf)
- [OSV: GHSA-x39x-9qw5-ghrf](https://osv.dev/vulnerability/GHSA-x39x-9qw5-ghrf)
- <https://github.com/browser-use/browser-use/security/advisories/GHSA-x39x-9qw5-ghrf>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-47241>
- <https://github.com/browser-use/browser-use/pull/1561>
- <https://github.com/browser-use/browser-use>
- <https://github.com/browser-use/browser-use/releases/tag/0.1.45>
- <https://github.com/pypa/advisory-database/tree/main/vulns/browser-use/PYSEC-2026-300.yaml>
- <https://pypi.org/project/browser-use>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-x39x-9qw5-ghrf>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-x39x-9qw5-ghrf/>. Everything for agents: <https://agentprime.io/llms.txt>.
