# Publify \`guest\` role users can self-register even when the admin does not allow it

Advisory record · `GHSA-x24j-87x9-jvv5`

- **Identifiers:** `GHSA-x24j-87x9-jvv5` · `BIT-publify-2021-25973` · `CVE-2021-25973`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-285](https://cwe.mitre.org/data/definitions/285.html) · [CWE-669](https://cwe.mitre.org/data/definitions/669.html) · [CWE-863](https://cwe.mitre.org/data/definitions/863.html)
- **Tags:** [Broken access control](https://agentprime.io/advisories/tag/access-control.md) · [CWE-669](https://agentprime.io/advisories/tag/cwe-669.md)
- **Published:** 3 Nov 2021
- **Updated:** 16 Feb 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 3 Nov 2021, 17:34 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `publify_core` (RubyGems): affected `>=9.0.0.pre1, <9.2.5`; fixed in `9.2.5`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`, from CNA (Mend)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0083, the 57th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 3 Nov 2021. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-x24j-87x9-jvv5](https://github.com/advisories/GHSA-x24j-87x9-jvv5)
- [OSV: GHSA-x24j-87x9-jvv5](https://osv.dev/vulnerability/GHSA-x24j-87x9-jvv5)
- <https://nvd.nist.gov/vuln/detail/CVE-2021-25973>
- <https://github.com/publify/publify/commit/3447e0241e921b65f6eb1090453d8ea73e98387e>
- <https://github.com/publify/publify>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/publify_core/CVE-2021-25973.yml>
- <https://www.whitesourcesoftware.com/vulnerability-database/CVE-2021-25973>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-x24j-87x9-jvv5>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-x24j-87x9-jvv5/>. Everything for agents: <https://agentprime.io/llms.txt>.
