# TorchServe vulnerable to bypass of allowed_urls configuration

Advisory record · `GHSA-wxcx-gg9c-fwp2`

- **Identifiers:** `GHSA-wxcx-gg9c-fwp2` · `CVE-2024-35198` · `PYSEC-2026-554`
- **State:** Confirmed
- **Severity:** CVSS 9.8 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-22](https://cwe.mitre.org/data/definitions/22.html) · [CWE-706](https://cwe.mitre.org/data/definitions/706.html)
- **Tags:** [Path traversal](https://agentprime.io/advisories/tag/path-traversal.md) · [CWE-706](https://agentprime.io/advisories/tag/cwe-706.md)
- **Published:** 18 Jul 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 18 Jul 2024, 22:03 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.8: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `torchserve` (PyPI): affected `<0.11.0`; fixed in `0.11.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> TorchServe versions before 0.11.0 are affected. The allowed_urls check can be bypassed by using a URL containing characters such as "..", which lets a model be downloaded into the model store, and the downloaded file can then be referenced later without a URL, defeating the allowlist. Upgrade to TorchServe 0.11.0, which validates URLs before downloading.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.8 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0080, the 56th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:35 UTC: First seen by agentprime
- 31 Oct 2026, 14:35 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-wxcx-gg9c-fwp2)

## Sources

- [GitHub Advisory Database: GHSA-wxcx-gg9c-fwp2](https://github.com/advisories/GHSA-wxcx-gg9c-fwp2)
- [OSV: GHSA-wxcx-gg9c-fwp2](https://osv.dev/vulnerability/GHSA-wxcx-gg9c-fwp2)
- <https://github.com/pytorch/serve/security/advisories/GHSA-wxcx-gg9c-fwp2>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-35198>
- <https://github.com/pytorch/serve/pull/3082>
- <https://github.com/pytorch/serve/commit/cdba0fd449c2fd23dcf37c54c0784035541d5114>
- <https://github.com/pytorch/serve>
- <https://github.com/pytorch/serve/releases/tag/v0.11.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-wxcx-gg9c-fwp2>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-wxcx-gg9c-fwp2/>. Everything for agents: <https://agentprime.io/llms.txt>.
