# ismp-grandpa crate accepted incorrect signatures

Advisory record · `GHSA-wwx5-gpgr-vxr7`

- **Identifiers:** `GHSA-wwx5-gpgr-vxr7` · `CVE-2025-24800`
- **State:** Confirmed
- **Severity:** CVSS 9.3 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-347](https://cwe.mitre.org/data/definitions/347.html) · [CWE-670](https://cwe.mitre.org/data/definitions/670.html)
- **Tags:** [Weak cryptography or TLS](https://agentprime.io/advisories/tag/weak-crypto.md) · [CWE-670](https://agentprime.io/advisories/tag/cwe-670.md)
- **Published:** 28 Jan 2025
- **Updated:** 28 Jan 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 Jan 2025, 17:29 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.3: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `ismp-grandpa` (crates.io): affected `<15.0.1`; fixed in `15.0.1`
- `grandpa-verifier-primitives` (crates.io): affected `<0.1.2`; fixed in `0.1.2`
- `grandpa-verifier` (crates.io): affected `<0.1.2`; fixed in `0.1.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.3 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0033, the 26th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:20 UTC: First seen by agentprime
- 31 Oct 2026, 15:20 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-wwx5-gpgr-vxr7)

## Sources

- [GitHub Advisory Database: GHSA-wwx5-gpgr-vxr7](https://github.com/advisories/GHSA-wwx5-gpgr-vxr7)
- [OSV: GHSA-wwx5-gpgr-vxr7](https://osv.dev/vulnerability/GHSA-wwx5-gpgr-vxr7)
- <https://github.com/polytope-labs/hyperbridge/security/advisories/GHSA-wwx5-gpgr-vxr7>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-24800>
- <https://github.com/polytope-labs/hyperbridge/pull/372/commits/f0e85db718f5165b06585a49b14a66f8ad643aea>
- <https://github.com/polytope-labs/ismp-substrate/pull/64/commits/04d5be207b082eb61d586d52e1685e2e060347e6#diff-4aedbca82d26bebc03f274e23fd5697c3346ffff54405c87af9018f3aef708b2R1-R160>
- <https://github.com/polytope-labs/ismp-substrate/pull/64/commits/5ca3351a19151f1a439c30d5cbdbfdc72a11f1a8#diff-3835cc24fb2011b3e8246036059acd8c2c2a9a869eedf7a210d18edb6543318dL262>
- <https://github.com/polytope-labs/ismp-substrate/pull/64/commits/b26894913b301061b07db61af841ca2586415f08#diff-493a6129d75fe31185e28695a4d2adc1582fe9df12462e380fe994f170fc1e70L159>
- <https://github.com/polytope-labs/hyperbridge>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-wwx5-gpgr-vxr7>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-wwx5-gpgr-vxr7/>. Everything for agents: <https://agentprime.io/llms.txt>.
