# Use of Cryptographically Weak Pseudo-Random Number Generator in yiisoft/yii2-dev

Advisory record · `GHSA-wwvv-x5mq-h3jj`

- **Identifiers:** `GHSA-wwvv-x5mq-h3jj` · `CVE-2021-3692` · `PKSA-26mg-s28k-sb3m`
- **State:** Confirmed
- **Severity:** CVSS 8.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-330](https://cwe.mitre.org/data/definitions/330.html) · [CWE-338](https://cwe.mitre.org/data/definitions/338.html) · [CWE-1241](https://cwe.mitre.org/data/definitions/1241.html)
- **Tags:** [Weak cryptography or TLS](https://agentprime.io/advisories/tag/weak-crypto.md) · [CWE-1241](https://agentprime.io/advisories/tag/cwe-1241.md)
- **Published:** 1 Sept 2021
- **Updated:** 8 Nov 2023
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 1 Sept 2021, 18:35 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `yiisoft/yii2-dev` (Packagist): affected `<2.0.43`; fixed in `2.0.43`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Yii 2 package yiisoft/yii2-dev versions before 2.0.43 are affected. The source gives few details, but it describes the issue as use of a predictable algorithm in a random number generator, which can allow an attacker to predict generated values. Upgrade yiisoft/yii2-dev to version 2.0.43 or later.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.1 High, CVSS 3.0: `CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`, from CNA (@huntrdev)

- **CISA KEV:** Not listed.
- **EPSS:** 0.017, the 77th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:33 UTC: First seen by agentprime
- 31 Oct 2026, 14:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-wwvv-x5mq-h3jj)

## Sources

- [GitHub Advisory Database: GHSA-wwvv-x5mq-h3jj](https://github.com/advisories/GHSA-wwvv-x5mq-h3jj)
- [OSV: GHSA-wwvv-x5mq-h3jj](https://osv.dev/vulnerability/GHSA-wwvv-x5mq-h3jj)
- <https://nvd.nist.gov/vuln/detail/CVE-2021-3692>
- <https://github.com/yiisoft/yii2/commit/13f27e4d920a05d53236139e8b07007acd046a46>
- <https://github.com/yiisoft/yii2>
- <https://huntr.dev/bounties/55517f19-5c28-4db2-8b00-f78f841e8aba>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-wwvv-x5mq-h3jj>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-wwvv-x5mq-h3jj/>. Everything for agents: <https://agentprime.io/llms.txt>.
