# Crass: A large number of adjacent CSS comments can trigger a SystemStackError

Advisory record · `GHSA-wwpr-jff3-395c`

- **Identifiers:** `GHSA-wwpr-jff3-395c` · `CVE-2026-61847`
- **State:** Confirmed
- **Severity:** CVSS 6.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-674](https://cwe.mitre.org/data/definitions/674.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 29 Oct 2026
- **Updated:** 29 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 29 Oct 2026, 16:35 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `crass` (RubyGems): affected `<1.0.7`; fixed in `1.0.7`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Versions of the crass Ruby gem before 1.0.7 are vulnerable. When the default setting that discards comments is in use, a stylesheet containing a very large number of adjacent CSS comments can cause excessive recursion and a SystemStackError, so an attacker who can supply stylesheet input can crash processing. Upgrade to crass 1.0.7, which no longer recurses when discarding comments. Alternatively, set the :preserve_comments option to true, since recursion does not occur when comments are preserved.

Written 3 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.3 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0049, the 41st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:21 UTC: First seen by agentprime
- 31 Oct 2026, 14:21 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-wwpr-jff3-395c)

## Sources

- [GitHub Advisory Database: GHSA-wwpr-jff3-395c](https://github.com/advisories/GHSA-wwpr-jff3-395c)
- [OSV: GHSA-wwpr-jff3-395c](https://osv.dev/vulnerability/GHSA-wwpr-jff3-395c)
- <https://github.com/rgrove/crass/security/advisories/GHSA-wwpr-jff3-395c>
- <https://github.com/rgrove/crass/commit/25d78cc607c54262e9d43ea1930f3ba5bb03dfb5>
- <https://github.com/rgrove/crass>
- <https://github.com/rgrove/crass/releases/tag/v1.0.7>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-wwpr-jff3-395c>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-wwpr-jff3-395c/>. Everything for agents: <https://agentprime.io/llms.txt>.
