# fast-jwt: Incomplete patch of CVE-2026-34950: Non-whitespace key-prefix re-enables RSA→HS256 algorithm confusion

Advisory record · `GHSA-ww5h-9m49-7xx4`

- **Identifiers:** `GHSA-ww5h-9m49-7xx4` · `CVE-2026-107722`
- **State:** Confirmed
- **Severity:** CVSS 9.8 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-347](https://cwe.mitre.org/data/definitions/347.html)
- **Tags:** [Weak cryptography or TLS](https://agentprime.io/advisories/tag/weak-crypto.md)
- **Published:** 8 Oct 2026
- **Updated:** 8 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 8 Oct 2026, 22:02 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.8: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `fast-jwt` (npm): affected `>=6.2.0, <6.3.0`; fixed in `6.3.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The fast-jwt npm package, versions 6.2.0 up to but not including 6.3.0, can still be tricked into RSA-to-HS256 algorithm confusion, because an incomplete fix for CVE-2026-34950 only strips whitespace before PEM detection. An attacker who knows the target's RSA public key can forge tokens that the verifier accepts when the key source has a non-whitespace leading character and no algorithms allowlist is set, which can yield authentication bypass. The source says fast-jwt 6.3.0 fixes the issue, so upgrade to 6.3.0 or later.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.8 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0036, the 29th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:33 UTC: First seen by agentprime
- 31 Oct 2026, 13:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-ww5h-9m49-7xx4)

## Sources

- [GitHub Advisory Database: GHSA-ww5h-9m49-7xx4](https://github.com/advisories/GHSA-ww5h-9m49-7xx4)
- [OSV: GHSA-ww5h-9m49-7xx4](https://osv.dev/vulnerability/GHSA-ww5h-9m49-7xx4)
- <https://github.com/nearform/fast-jwt/security/advisories/GHSA-ww5h-9m49-7xx4>
- <https://github.com/nearform/fast-jwt/pull/632>
- <https://github.com/nearform/fast-jwt/commit/d96bbc6c5336055a6dbfa318fdbab01197264cfa>
- <https://github.com/nearform/fast-jwt>
- <https://github.com/nearform/fast-jwt/releases/tag/v6.3.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-ww5h-9m49-7xx4>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-ww5h-9m49-7xx4/>. Everything for agents: <https://agentprime.io/llms.txt>.
