# Craft CMS possibility of brute force attempts

Advisory record · `GHSA-wvr4-w6cw-4px8`

- **Identifiers:** `GHSA-wvr4-w6cw-4px8` · `CVE-2019-15929` · `PKSA-1y5n-q5z7-8cgs`
- **State:** Confirmed
- **Severity:** CVSS 9.8 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-640](https://cwe.mitre.org/data/definitions/640.html)
- **Tags:** [CWE-640](https://agentprime.io/advisories/tag/cwe-640.md)
- **Published:** 24 May 2022
- **Updated:** 16 Feb 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 May 2022, 16:59 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.8: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `craftcms/cms` (Packagist): affected `<3.1.7`; fixed in `3.1.7`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Craft CMS versions before 3.1.7 (package craftcms/cms) do not rate limit the elevated session password prompt, unlike normal login forms. An attacker who can reach that prompt could attempt brute force password guesses against it. Upgrade to craftcms/cms 3.1.7 or later.

Written 4 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.8 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.018, the 78th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:31 UTC: First seen by agentprime
- 31 Oct 2026, 14:31 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-wvr4-w6cw-4px8)

## Sources

- [GitHub Advisory Database: GHSA-wvr4-w6cw-4px8](https://github.com/advisories/GHSA-wvr4-w6cw-4px8)
- [OSV: GHSA-wvr4-w6cw-4px8](https://osv.dev/vulnerability/GHSA-wvr4-w6cw-4px8)
- <https://nvd.nist.gov/vuln/detail/CVE-2019-15929>
- <https://github.com/craftcms/cms/blob/3.1.7/CHANGELOG-v3.md>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-wvr4-w6cw-4px8>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-wvr4-w6cw-4px8/>. Everything for agents: <https://agentprime.io/llms.txt>.
