# PrestaShop Checkout Target PayPal merchant account hijacking from backoffice

Advisory record · `GHSA-wvpg-4wrh-5889`

- **Identifiers:** `GHSA-wvpg-4wrh-5889` · `CVE-2025-61924` · `PKSA-2hfz-bts5-gnys`
- **State:** Confirmed
- **Severity:** CVSS 3.8 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-184](https://cwe.mitre.org/data/definitions/184.html)
- **Tags:** [CWE-184](https://agentprime.io/advisories/tag/cwe-184.md)
- **Published:** 16 Oct 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 16 Oct 2025, 20:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `prestashop/ps_checkout` (Packagist): affected `<4.4.1 || >=5.0.0, <5.0.5`; fixed in `4.4.1`, `5.0.5`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The PrestaShop Checkout module (Packagist prestashop/ps_checkout) is vulnerable in versions before 4.4.1 and from 5.0.0 before 5.0.5. The source attributes the flaw to incorrect use of PHP's array_search() that allows validation to be bypassed, and the title indicates it relates to hijacking a PayPal merchant account from the backoffice, though the source gives few other details on the required access or exact impact. Upgrade to version 4.4.1 or 5.0.5, depending on your PrestaShop release line.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.8 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0027, the 19th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:03 UTC: First seen by agentprime
- 31 Oct 2026, 14:03 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-wvpg-4wrh-5889)

## Sources

- [GitHub Advisory Database: GHSA-wvpg-4wrh-5889](https://github.com/advisories/GHSA-wvpg-4wrh-5889)
- [OSV: GHSA-wvpg-4wrh-5889](https://osv.dev/vulnerability/GHSA-wvpg-4wrh-5889)
- <https://github.com/PrestaShopCorp/ps_checkout/security/advisories/GHSA-wvpg-4wrh-5889>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-61924>
- <https://github.com/PrestaShopCorp/ps_checkout>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-wvpg-4wrh-5889>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-wvpg-4wrh-5889/>. Everything for agents: <https://agentprime.io/llms.txt>.
