# vLLM is vulnerable to timing attack at bearer auth

Advisory record · `GHSA-wr9h-g72x-mwhm`

- **Identifiers:** `GHSA-wr9h-g72x-mwhm` · `CVE-2025-59425` · `PYSEC-2026-2026`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-385](https://cwe.mitre.org/data/definitions/385.html)
- **Tags:** [CWE-385](https://agentprime.io/advisories/tag/cwe-385.md)
- **Published:** 7 Oct 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 7 Oct 2025, 17:24 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `vllm` (PyPI): affected `<0.11.0`; fixed in `0.11.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> vLLM versions before 0.11.0 are vulnerable to a timing attack on API key validation, because the key check used a string comparison that takes longer the more leading characters match. An attacker who can send many requests to a deployment using vLLM's built-in API key authentication could use timing measurements to recover a valid key more efficiently than brute force. Upgrade to vLLM 0.11.0 or later.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0057, the 47th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:34 UTC: First seen by agentprime
- 31 Oct 2026, 14:34 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-wr9h-g72x-mwhm)

## Sources

- [GitHub Advisory Database: GHSA-wr9h-g72x-mwhm](https://github.com/advisories/GHSA-wr9h-g72x-mwhm)
- [OSV: GHSA-wr9h-g72x-mwhm](https://osv.dev/vulnerability/GHSA-wr9h-g72x-mwhm)
- <https://github.com/vllm-project/vllm/security/advisories/GHSA-wr9h-g72x-mwhm>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-59425>
- <https://github.com/vllm-project/vllm/commit/ee10d7e6ff5875386c7f136ce8b5f525c8fcef48>
- <https://github.com/advisories/GHSA-wr9h-g72x-mwhm>
- <https://github.com/pypa/advisory-database/tree/main/vulns/vllm/PYSEC-2026-2026.yaml>
- <https://github.com/vllm-project/vllm>
- <https://github.com/vllm-project/vllm/blob/4b946d693e0af15740e9ca9c0e059d5f333b1083/vllm/entrypoints/openai/api_server.py#L1270-L1274>
- <https://github.com/vllm-project/vllm/releases/tag/v0.11.0>
- <https://pypi.org/project/vllm>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-wr9h-g72x-mwhm>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-wr9h-g72x-mwhm/>. Everything for agents: <https://agentprime.io/llms.txt>.
