# sharp : Vulnerability in librsvg dependency CVE-2026-96889

Advisory record · `GHSA-wq5f-xc86-pv6w`

- **Identifiers:** `GHSA-wq5f-xc86-pv6w` · `CVE-2026-114111`
- **State:** Confirmed
- **Severity:** CVSS 8.9 High
- **Critical:** No
- **Weakness (CWE):** [CWE-416](https://cwe.mitre.org/data/definitions/416.html) · [CWE-1395](https://cwe.mitre.org/data/definitions/1395.html)
- **Tags:** [Memory corruption](https://agentprime.io/advisories/tag/memory-corruption.md) · [CWE-1395](https://agentprime.io/advisories/tag/cwe-1395.md)
- **Published:** 6 Oct 2026
- **Updated:** 21 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 6 Oct 2026, 13:43 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `sharp` (npm): affected `<0.35.5`; fixed in `0.35.5`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The sharp npm package versions below 0.35.5 are affected by a memory-related vulnerability in its bundled librsvg dependency, which the source says can lead to remote code execution on glibc-based Linux under certain runtime conditions. The source does not describe what an attacker must do beforehand, such as supplying a crafted SVG image, though sharp's decoding of SVG images is the relevant path. Upgrade sharp to 0.35.5 or later, which provides librsvg 2.63.2; users with a globally installed librsvg should move to librsvg 2.63.2.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.9 High, CVSS 4.0: `CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`, from CNA (VulnCheck)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0013, the 2nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:33 UTC: First seen by agentprime
- 31 Oct 2026, 13:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-wq5f-xc86-pv6w)

## Sources

- [GitHub Advisory Database: GHSA-wq5f-xc86-pv6w](https://github.com/advisories/GHSA-wq5f-xc86-pv6w)
- [OSV: GHSA-wq5f-xc86-pv6w](https://osv.dev/vulnerability/GHSA-wq5f-xc86-pv6w)
- <https://github.com/lovell/sharp/security/advisories/GHSA-wq5f-xc86-pv6w>
- <https://github.com/lovell/sharp/commit/96de105d9d36ab04c76c2b78b97255171630d236>
- <https://github.com/lovell/sharp>
- <https://github.com/lovell/sharp/releases/tag/v0.35.5>
- <https://gitlab.gnome.org/GNOME/librsvg/-/work_items/1241>
- <https://www.cve.org/CVERecord?id=CVE-2026-96889>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-wq5f-xc86-pv6w>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-wq5f-xc86-pv6w/>. Everything for agents: <https://agentprime.io/llms.txt>.
