# Possible shell escape sequence injection vulnerability in Rack

Advisory record · `GHSA-wq4h-7r42-5hrr`

- **Identifiers:** `GHSA-wq4h-7r42-5hrr` · `CVE-2022-30123`
- **State:** Confirmed
- **Severity:** CVSS 10.0 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-150](https://cwe.mitre.org/data/definitions/150.html)
- **Tags:** [CWE-150](https://agentprime.io/advisories/tag/cwe-150.md)
- **Published:** 27 May 2022
- **Updated:** 18 Feb 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 27 May 2022, 16:36 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 10.0: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `rack` (RubyGems): affected `<2.0.9.1 || >=2.1, <2.1.4.1 || >=2.2, <2.2.3.1`; fixed in `2.0.9.1`, `2.1.4.1`, `2.2.3.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 10.0 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.020, the 80th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 27 May 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-wq4h-7r42-5hrr](https://github.com/advisories/GHSA-wq4h-7r42-5hrr)
- [OSV: GHSA-wq4h-7r42-5hrr](https://osv.dev/vulnerability/GHSA-wq4h-7r42-5hrr)
- <https://nvd.nist.gov/vuln/detail/CVE-2022-30123>
- <https://github.com/rack/rack/commit/b426cc224908ec6ed6eb8729325392b048215d88>
- <https://discuss.rubyonrails.org/t/cve-2022-30123-possible-shell-escape-sequence-injection-vulnerability-in-rack/80728>
- <https://github.com/rack/rack>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rack/CVE-2022-30123.yml>
- <https://groups.google.com/g/ruby-security-ann/c/LWB10kWzag8>
- <https://security.gentoo.org/glsa/202310-18>
- <https://security.netapp.com/advisory/ntap-20231208-0011>
- <https://www.debian.org/security/2023/dsa-5530>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-wq4h-7r42-5hrr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-wq4h-7r42-5hrr/>. Everything for agents: <https://agentprime.io/llms.txt>.
